2006+ Honda Civic Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Idle at a stop seems fine (800rpm, give or take 10), but when coasting to a stop or downhill in neutral (doesn't matter if in gear with clutch disengaged or in neutral) the idle rpms are all over the place. Car runs fine otherwise, no problems accelerating or anything when driving.


Not sure if related, but even when the car is fully warmed up, the RPM at startup jumps to 2k+ and takes about 20 seconds to settle down, is this normal?


Again not sure if related but I like giving data, I found out my PCV valve might be bad, a hissing sound is coming from it, but goes away when the hose is pinched.


Thanks.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
vaccum leak.
But that would cause the standing idle to be abnormal also, no? It's only happening when rolling in neutral. My bet is the TPS needs recalibrating, I'm trying to find somebody with an OBD2 bidirectional scanner.

Also noticed that when standing in neutral (around 800 rpm idle so normal) and I rev the car slightly, say 1700 rpm and I immediately let go of the pedal the rpms drop to 1200 then surge back to 1500 and then go back down slowly again. It's really strange. This could be the cause of the massive rev hang I'm getting when shifting gears.
 

·
Super Moderator
Joined
·
2,116 Posts
maybe needs the tps reset after cleaning
thats if you cleaned it properly and its not damaged or contaminated any sensors
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
maybe needs the tps reset after cleaning
thats if you cleaned it properly and its not damaged or contaminated any sensors
Yes that's what I gathered from googling around.

I probably did not damage anything, didn't even remove the TB, just the plastic air tube, put a brick on the throttle pedal to open it and gently wiped away the black stuff, I don't think I touched anything in there. A faulty PCV valve doesn't give these symptoms right?
 

·
Premium Member
Joined
·
2,224 Posts
But that would cause the standing idle to be abnormal also, no? It's only happening when rolling in neutral. My bet is the TPS needs recalibrating, I'm trying to find somebody with an OBD2 bidirectional scanner.

Also noticed that when standing in neutral (around 800 rpm idle so normal) and I rev the car slightly, say 1700 rpm and I immediately let go of the pedal the rpms drop to 1200 then surge back to 1500 and then go back down slowly again. It's really strange. This could be the cause of the massive rev hang I'm getting when shifting gears.
I'd still say a vacuum leak, as when it's under load it's probably sealing fine... then once you let off it's closing the throttle plate putting pressure on where the leak is.

Costs nothing to undo everything and ensure all mating surfaces are clean and flush.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
Tested for vacuum leaks, everything is OK.

Resetting the ECM and then doing the relearn solved the idle surging issue. So again, if I just followed the service book after cleaning the TB I would have been fine.

I will replace the PCV valve, too.
 

·
Registered
Joined
·
36 Posts
Razon...

You got a link to the correct ECM reset and idle relearn guide that you used?

Ive just cleaned my throttle body while still on car, had weight on pedal to keep throttle fully open, think i may have put too much carb cleaner in there, and i sprayed it in all over the thing a few times then cleaned / wiped dry with paper towel

My cars now doing exactly the same as your video there,
goes upto 2.5k revs on start up and when driving if you put it in neutral and roll the engine keeps revving upto to nearly 2.5k by itself.... And horrendous rev hang when changing gears.

Dunno what it is with these cars but everytime you do something to try make it better theres always issues after it...
 
1 - 10 of 10 Posts
Top