2006+ Honda Civic Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
looked throu post's and could not see anything on this I have a 2007 CTR FN2 last couple of weeks the wipers work but they stop randomly in different places some times when at fully open sometimes in middle of screen some times where they should sit when not working

is this the sensor gone ( they still start when rains ) or something else ie motor ?

any advise help comments would be great

thanks in advance

Daz
 

·
Premium Member
Joined
·
10,524 Posts
I've had it a couple of times on older cars and it's either the relay or the return contact on the motor. The relays a lot cheaper so try it first . It's in beside the fuse box of imagine as I've never needed to look on the Civic
 

·
D and A said i did it
Joined
·
450 Posts
Had it on other cars, clean and lubricate the mechanism or it will continue putting strain on the motor which costs a lot more to replace.
 

·
Registered
Joined
·
286 Posts
Take motor out, take motor apart, and clean all electrical contacts with a contact/switch spray. Try RS components or Maplins for the spray. I would echo the advice/opinions of other posters here, but in my case on a Pug it was the self park switch. Motor needs to come out anyway, so you have little to loose by having a go at fixing it yourself.
 

·
Registered
Joined
·
613 Posts
Yep, definitely wiper motor. Had the same issue on mine and cleaned the wiper motor over a year ago, been fine since.
 

·
#MrGrumpy
Joined
·
13,117 Posts
1 - 12 of 12 Posts
Top