2006+ Honda Civic Forum banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
39 Posts
I know this is an old post but saves starting a new one ..

I have this same problem .. Is it just a case of loose wire if not what will I be looking at replacing (glass,folding motor,fuse) ?
 

·
Premium Member
Joined
·
172 Posts
Took the mirror out, the wires seem ok and connected ?
I've got the same problem. Started this morning :/

I read through a few other posts on the site - looks like it's either a dodgy connection to the motor/heater, the mirror glass, or the actuator/motor (which is also the heater apparently).

Did the glass come out easily? I was going to try tonight - other posts just say tilt it to one side and pull gently...is that right?

If it's the glass, then that's only £30 from Honda and sounds like a 5 minute fix. If it's the motor that's £65 and not a 5 minute fix :(

Have you got anywhere with yours since you last posted??
 

·
Registered
Joined
·
613 Posts
The glass comes out easy. Put a screwdriver behind the far edge (furthest from the car) and lever it out, it will come out pretty easy. The heating element is the two wires going to the back of the glass.
 

·
Premium Member
Joined
·
914 Posts
My side mirror is barely heating recently, it works "a bit", but it isn't enough to remove fog in reasonable time (it's +2 °C on the left side compared to +9 °C on the right side after a few minutes), will try to fix it this week
 

·
Premium Member
Joined
·
12 Posts
Heater not working

Had the same problem with heater not working. Took glass out and cleaned connections. Now working ok. Was surprised as the connectors were hard to pull off.

Keep up the good work. This forum has already saved me a couple of hundred pounds
 

·
Premium Member
Joined
·
471 Posts
Had the same problem with heater not working. Took glass out and cleaned connections. Now working ok. Was surprised as the connectors were hard to pull off.

Keep up the good work. This forum has already saved me a couple of hundred pounds
New guy question, how can I get at these connections? I got a feeling mine don't work or I don't have any as I recently remember having to wipe my side mirrors with my finger in order to get a clear sight when reserving. Can I do a check to see if I have them?:facepalm:
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top