2006+ Honda Civic Forum banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
369 Posts
Discussion Starter #1
My rear heated screen doesnt seem to work very well, anybody else with same problem, takes ages to clear and has done from new, seems like not enough current going through it. On average about 20 mins before it clears the mist on these cold mornings.

cheers
sie
 

·
Premium Member
Joined
·
502 Posts
My one takes effect immediately. Can see it working within a minute of turning it on. Maybe fully demisted in 5 minutes.
 

·
Premium Member
Joined
·
258 Posts
My rear heated screen doesnt seem to work very well, anybody else with same problem, takes ages to clear and has done from new, seems like not enough current going through it. On average about 20 mins before it clears the mist on these cold mornings.

cheers
sie
With the recent sub -5C temperatures we having been having it does seem to struggle. I suppose its directly proportional to the outside temperature as to how rapidly it defrosts.
 

·
Premium Member
Joined
·
22,623 Posts
With the recent sub -5C temperatures we having been having it does seem to struggle. I suppose its directly proportional to the outside temperature as to how rapidly it defrosts.
It is yes, as delta T increases the amount of energy needed will increase.

However, I find mine melts ice quite quickly, so 20 mins to clear some mist sounds a lot.
 

·
Premium Member
Joined
·
502 Posts
Yeah the time I've been in Reading which dropped to -6c the other night my car demister worked perfectly fine and fast, just to confirm.
 

·
Administrator
Joined
·
19,185 Posts
Mine works fine and quickly in about -10 to -15 as we had here last week. On a journey of 10 mins it had done it's job.
 

·
Registered
Joined
·
429 Posts
I find my heated rear window iis virtually useless. It dos not matter if it is thin or thick ice. Apart from a vaque outline where the wire goes nothing melts. It is the most useless heated window I have ever had. My wife's Ford Fiesta melts the the ice within 1 minute.

I also fine that when driving, my 2 mirrers mist over totally and then suddenly clear. It's very disconcerting.

I am asking the dealerto look at it when in next week to have the sticking roof lining repaired.
 

·
Premium Member
Joined
·
369 Posts
Discussion Starter #8
I cant understand how some work really well and mine works on every line but not ver well ??? can the dealer alter the voltage that runs through the screen ? i would of thought that they either work or dont.
 

·
Premium Member
Joined
·
22,623 Posts
I cant understand how some work really well and mine works on every line but not ver well ??? can the dealer alter the voltage that runs through the screen ? i would of thought that they either work or dont.
I would have though that too, I seriously doubt there is a pot somewhere to turn.

Intermittent connection somewhere perhaps?
 

·
Premium Member
Joined
·
355 Posts
No, no problems here. I also love watching the mirrors steaming too when waiting to defrost screens.
 

·
Registered
Joined
·
429 Posts
My dealer tells me my heated rear window was not plugged in. I have yet to test it now that it has been plugged in at last. This is just one more example of poor build quality as it has never removed ice since new.

I'll wait for some frost to test it out before I get to excited!
 

·
Registered
Joined
·
429 Posts
I was able to test my now plugged in heated rear window this morning. From rock solid ice it was all cleared within 2 minutes when I turned the heater on.

It's just a shame I suffered all last winter clearing it with a scraper.
 

·
Registered
Joined
·
2 Posts
hrw

does the lower rear window have heating elements on it , the missus says she cant see anything out of the rear lower window cheers.
 

·
Registered
Joined
·
300 Posts
In the Summer Months I thought I may have had a fault with the Heated Rear Window as it didn't seem to remove water or mist, but having used the heater in the Winter Months it seems fine removing Frost.
 

·
geekess
Joined
·
3,638 Posts

·
Premium Member
Joined
·
136 Posts
i have noticed the top four or so elements dont work very well, i also think this could be tied in with the poor radio reception... as i am lead to beleive these top elements are also the radios ariel, is this true and has anyone else had similar occurances?
 
1 - 17 of 17 Posts
Top