2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 07 Civic has recently got a problem: the heater blower fails to start intermittently when turned on. Sometimes it kicks into action after few minutes of drive. Most often, a sharp left turn seems to trigger it into action. Once it starts, it will continue to work.

I had the resistor replaced by dealer but that did not fix the problem. Now the dealer is thinking of replacing the motor assembly itself but I am not entirely convinced, as I guess if the motor had gone, it would stop working all together.

Anyone got any similar issues/experiences and idea what might be at fault for such intermittent failure?
 

·
Administrator
Joined
·
17,934 Posts
Welcome to :civinfo:

Replace the fuse?

Check electrical connections?

Check for worn loom/wires?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks, Farqui.
I explicitly asked the dealer to check relay/fuse/connection and can only hope they did. They are talking about motor assembly but do not sound entirely confident. I am also not convinced as the motor works fine once started - it just does not start from time to time:-(
 

·
Administrator
Joined
·
17,934 Posts
Sounds like you need a second opinion, maybe even from an auto electrician.

Good luck and let us know how you get on.
 

·
Registered
Joined
·
365 Posts
Sometimes it kicks into action after few minutes of drive.
That sounds like expected behaviour to me. If you've got the fans set to auto they don't start until the engine has warmed up.
I'll second that. I've had an 8th gen and in cooler months it will not blow till the engine warms up.
 
1 - 7 of 7 Posts
Top