2006+ Honda Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1 (Edited)
Hi, all.

Just in time for the cold weather - my heater is not blowing any air at all. When I turn the heater on (either 'Auto', or the manual speed switches), nothing comes through the vents. The revs drop as soon as I turn them on (they pick-up afterwards - just the alternator catching-up), and the display doesn't show anything out of the ordinary. There is also a single click when I turn the temperature from 'Lo' to 'Hi' - which, again, I think is normal. However, there is literally nothing blowing through.

Any ideas?

Thanks in advance.

Edit: I've just changed fuse 19 - no joy. The rear heater/mirror heater still works. Earlier today, the heater sounded like there was something stuck inside - and then it just stopped working.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #2
Update:

After some research, I have come to the conclusion that the blower motor resistor is to blame for the fans not working. I have ordered a new one, and it is coming in a couple of weeks (12V heater will have to do for now). Does anyone have any tips regarding changing the resistor? Does the clutch pedal have to come off for this, or is it not as big a job as changing the whole motor? Will get down and have a look when I get chance - but just wanted some advice in the meantime.

Thanks
 

·
Super Moderator
Joined
·
2,068 Posts
Update:

After some research, I have come to the conclusion that the blower motor resistor is to blame for the fans not working. I have ordered a new one, and it is coming in a couple of weeks (12V heater will have to do for now). Does anyone have any tips regarding changing the resistor? Does the clutch pedal have to come off for this, or is it not as big a job as changing the whole motor? Will get down and have a look when I get chance - but just wanted some advice in the meantime.

Thanks
only have to remove the clutch pedal if removing the motor
the resistor comes out nice and easy
if its just the resistor also change the pollen filter as they recon its the blocked/dirty pollen filter that's puts the extra strain on the resistor unit
 
1 - 3 of 3 Posts
Top