2006+ Honda Civic Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
168 Posts
Discussion Starter · #1 ·
So... Recently my left indicator stopped working all together, and due to this the clicking and flashing of the other two indicators on the left (wing mirror and rear) are flashing twice as fast.

I have replaced the bulb which was the only one not working. So now I'm stuck on what to do. I would check the fuse but it doesn't indicate in the manual which fuse is for the indicator bulbs? does anyone here know?

Any tips are very very welcome
 

·
Premium Member
Joined
·
19 Posts
I would think you have an open circuit at the indicator thats not working.Supply wiring or the bulb holder. Check for corrosion/poor contact with bulb, Give contacts a good clean, even the lead solder on the bulb. Possible break in the wiring, if no joy with that. As the other indicator is working, I wouldn't think its on seperate fused circuit. I could be wrong. Flash frequency seems load dependant, so with 1 indicator 'out' its flashing faster.
 

·
Premium Member
Joined
·
168 Posts
Discussion Starter · #4 ·
I would think you have an open circuit at the indicator thats not working.Supply wiring or the bulb holder. Check for corrosion/poor contact with bulb, Give contacts a good clean, even the lead solder on the bulb. Possible break in the wiring, if no joy with that. As the other indicator is working, I wouldn't think its on seperate fused circuit. I could be wrong. Flash frequency seems load dependant, so with 1 indicator 'out' its flashing faster.
you are exactly correct. It wasn't even the bulb, it was the connection! I used some thin pliers to nip the pins inside the connect back into place so the connection was nice and tight, and hey presto it works perfectly!

Thanks!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top