2006+ Honda Civic Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Has anybody come across an issue with there lowering springs. I recently had eibach 15mil springs fitted to my fn2 with a fast road set up at the same time. I seem to have an issue with a knocking noise when turning left. Initially I thought the noise was coming from the front passenger wheel area. But I'm just not sure. I keep thinking Mabe it's the springs just settling in as I imagine they need abit of time to slightly soften up but the noise is starting to annoy me now. Has anybody else had this issue when lowering? Or something similar


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
253 Posts
Has anybody come across an issue with there lowering springs. I recently had eibach 15mil springs fitted to my fn2 with a fast road set up at the same time. I seem to have an issue with a knocking noise when turning left. Initially I thought the noise was coming from the front passenger wheel area. But I'm just not sure. I keep thinking Mabe it's the springs just settling in as I imagine they need abit of time to slightly soften up but the noise is starting to annoy me now. Has anybody else had this issue when lowering? Or something similar


Sent from my iPhone using Tapatalk
Did you get the springs fitted at a garage, if so I would give them a call and explain the issue. It may be excess play in the anti rollbar drop link or perhaps a worn strut top mount. I have the same setup on mine and got the drop links replaced when the springs were fitted; there should be no bedding in period per se. Also, check that your OSF wheel nuts have been re-torqued correctly and are not loose.

Sent from my D6503 using Tapatalk
 

·
Registered
Joined
·
82 Posts
Discussion Starter #3
Thanks for the reply Steve T. Yes a garage fitted the springs aswell as doing a frsu. I know it's something to do with the springs being fitted as I previously never had this knocking noise. I have spoke to the garage they are more than happy to check it over as soon as I get a day off to get up to them. I was just trying to rule out anything simple and avoid going back to be honest as it's an hours drive away from were I live. Wasn't sure if it's a common thing and disappears. Guess if it persists I'll be going back, the car has only done 33k so I wouldn't have imagined drop links cv joints or anything of that nature would have excessive wear. Thanks for the reply


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
253 Posts
Thanks for the reply Steve T. Yes a garage fitted the springs aswell as doing a frsu. I know it's something to do with the springs being fitted as I previously never had this knocking noise. I have spoke to the garage they are more than happy to check it over as soon as I get a day off to get up to them. I was just trying to rule out anything simple and avoid going back to be honest as it's an hours drive away from were I live. Wasn't sure if it's a common thing and disappears. Guess if it persists I'll be going back, the car has only done 33k so I wouldn't have imagined drop links cv joints or anything of that nature would have excessive wear. Thanks for the reply


Sent from my iPhone using Tapatalk
No worries... Just as an aside my droplinks were worn and needed replacing (they were knocking) and car was on 42k. You need to remove the droplinks when changing the springs so if yours have been 'disturbed' that may have contributed to your issue?

Sent from my D6503 using Tapatalk
 

·
Registered
Joined
·
82 Posts
Discussion Starter #5
I never thought about this, I guess it's not going to just disappear, no way to it other than getting it back in I guess.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
253 Posts
I never thought about this, I guess it's not going to just disappear, no way to it other than getting it back in I guess.


Sent from my iPhone using Tapatalk
Afraid it's unlikely to disappear; you can check the obvious first but I'd be going back to the garage and getting the camber bolts, links, arb bushes, bump stops and top mounts checked... It may be worth bagging a set of Meyle droplinks off eBay (~£40) before you go.

Sent from my D6503 using Tapatalk
 

·
Registered
Joined
·
82 Posts
Discussion Starter #10
I sorted it, the garage said the springs had slipped out of position slightly from the top mount, put back in greased up and all good now


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top