2006+ Honda Civic Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello I am just wondering if anybody can help I have had a knocking noise for while now and it has gotten progressively worse from reading posts on here I decided to change my ARB links but the noise continued. I decided to check all of the lower suspension components and I have noticed that the lower control arm rubber looks to be deteriorated so I have ordered a new bushing and mount however on closer inspection I noticed that next to the mount there is also what looks to be a bolt hole and I am wondering if this is whats causing the issue (the lack of bolts) and if it is not the route of the issue then whether it is a safety hazard not having one. I have included an image of the mount and the "bolt hole" below to give you an idea of what i mean. I will be changing the mount and bushings tomorrow and if anyone could give me an idea of how much of a pain getting the bush off and back on will be that would be great too. Thanks in advance.
313009
 

·
Registered
Joined
·
368 Posts
You don't have a bolt missing on your subframe.
The hole there is to align the subframe correctly if you were to drop the subframe.

As for your knock, it could be anything. When are you experiencing the noise? Instead of throwing the parts cannon at it, take it to a mechanic and have them get it on the lift and hang off the suspension parts with a long bar. They'll diagnose it for you.

Don't go to a mechanic without a good reputation as they could just guess.
 

·
Ex-Pat Geordie!
Joined
·
2,312 Posts
Did you put he bolts back in the correct holes? They are not all the same length and when I did mine a couple of year ago I made that error....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Yeah all of the bolts are in the correct holes and I have been to a mechanic and they are pointing at the anti roll bar bushes which are a relatively cheap fix so some good news there
 
1 - 4 of 4 Posts
Top