2006+ Honda Civic Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
hi i got a 2.2 2006 civic, only had it just over a month and the display on way home tonight had bits (pixels) missing is this a common problem is there a way to reset. Is it the actual display that is broken or the headunit.
 

·
Premium Member
Joined
·
317 Posts
Hi, mine has the same problem,i have everthing showing all at once.:confused:The problem does come and go though:(, I have been told that the head unit is on it's way out:facepalm:
 

·
Registered
Joined
·
69 Posts
Discussion Starter #7
Happened again today just some of pixels missing so the 8 now looked like a 6 etc. Gave dashboard above display a tap and all worked again, I'm now thinking a possible loose connection.
 

·
Registered
Joined
·
1,461 Posts
I have fixed two of these in the past on different cars. Both were caused by a dry soldered joint on the input connector, effectively a bad connection.

First step would be to remove plastic panels and jiggle the cable, see if that has an effect.
 

·
Registered
Joined
·
179 Posts
Audio equipment is usually excluded from warranties, at least with used car warranties anyway. Worth a try though - you really don't want to get a quote on a new headunit, a Euromillions win would be needed to replace
 

·
Deluded FK2 Owner
Joined
·
561 Posts
Has anybody posted a guide on how to remove the LCD display? I'm guessing I don't need to remove the head unit to get it out to see if it can be fixed with a bit of soldering?
 
1 - 13 of 13 Posts
Top