2006+ Honda Civic Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi Everyone.

im new to civics and new here.

Both powerfold mirrors don’t work. I have just bought a side mirror relay S.O.D. Only problem is the connections are different, and I don’t know the best way to proceed

could someone help me please?

thanks in advance
 

Attachments

·
Premium Member
Joined
·
616 Posts
I've changed quite a few of these in different age mk8 civic and they have all been the same. That other ones maybe from a different model
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi. Thanks for your reply (my first communication)

its an early mk8 (2005). I don’t understand why my connectors are different, they all look factory made, I’m sure of that

so, I’m confused. Lol
 

·
Premium Member
Joined
·
366 Posts
Send an email, with photo attached, to cox motor parts, they might be able to help.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
They all seem to be that design. So it’s not the ‘wrong one’. I was trying to ascertain why my wiring is different, and the best way to fit it

i cut the old plug off the old one and soldiered it to the new one and heatshrinked it.

I bought it from eBay seller: qdi_ltd for £27.49. But when I took the plug of it it had like 5 tiny strands of copper. Compared to the original Honda which had about 20 thicker strands of copper, so it made a weak soldier joint, but time will tell. All fitted and working well.

case closed... simples. Lol
thanks for the help guys
 
1 - 6 of 6 Posts
Top