2006+ Honda Civic Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Hi, ive got a civic 57 plate 1.8s. Its been great from new until last week when the Check System light came on, followed by the check VSA, Check Airbags, Check ABS and a host of other various 'check' lights. this continues for about 3 cycles, during which the speedometer dosent display the speed, finally it just says check system.

Put it into Honda and they said they didnt know and even Honda Technical were struggling, they took it in for a full day and said there was an issue with the electronics harness, and its fixed now. This fixed it for 2 days, then the fault came back, but not everytime as it was previously.

Ive booked it back into honda, theyve advised that if the ECU needs renewing then it will set me back £700 plus labour to fit, ive already spent £250 with Honda when they tried to diagnose the fault.

Just wondering if anybody else has seen this issue.
 

·
無限 Unlimited
Joined
·
3,740 Posts
I know your car is just over 3yrs, but only just. I'd argue for it to be covered under warranty. Sounds like they are guessing as to what the fault is if they weren't able to pin point it before, are they absolutely certain the ECU needs renewing? what do they say the reason for failure is? A £1000 just to see if that will cure the issue is a lot of money. Maybe a snotty letter to Honda UK is in order?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
They havent said what the failure was other than there was an issue with the wiring harness, so why they are quoting me £700 for an ecu is anybodies guess, its booked in tomorrow again for further investigation, ive no confidence that they have any sort of clue why this is occurring, but i agree with you, i will be writing to Honda Customer service today.
 

·
無限 Unlimited
Joined
·
3,740 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Yes good logic ill be asking them to demonstrate that this ecu will work first before taking this any further, i'll contact Honda using that email address. thanks for that. The reason i bought a Honda in the first place was to get away from these sort of ECU related poor quality issues that i was previously plagued with on Vauxhall's, i was just about to buy another Honda but this has put me right off. Its not the sort of issue youd expect to get with Honda and im certainly not happy about paying over £1000 to rectify on a 4 year old car.
Thanks for you help :)
 

·
無限 Unlimited
Joined
·
3,740 Posts
No probs.

Also try Duncans suggestion, worth a try and won't cost you a thing. It is known that the OEM batterys aren't that great and a weak battery may cause the same symptoms as Duncan says.

Perhaps you can also take the battery out and give it a quick charge for a few hours before putting it back in.
 
  • Like
Reactions: DUNCAN

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Yep good suggestion, ive not got the car at the moment so cant try the battery, my wife has it at work till 11 tonight, and as its in again with Honda first thing i'll be asking them if they have tried that, i can borrow a battery charger tomorrow so ill see what they come up with tomorrow, meanwhile im putting together an email to Honda. Again, thanks for your help. ill let you know how i get on tomorrow.
 

·
Premium Member
Joined
·
1,177 Posts
Hi, ive got a civic 57 plate 1.8s. Its been great from new until last week when the Check System light came on, followed by the check VSA, Check Airbags, Check ABS and a host of other various 'check' lights. this continues for about 3 cycles, during which the speedometer dosent display the speed, finally it just says check system.

Put it into Honda and they said they didnt know and even Honda Technical were struggling, they took it in for a full day and said there was an issue with the electronics harness, and its fixed now. This fixed it for 2 days, then the fault came back, but not everytime as it was previously.

Ive booked it back into honda, theyve advised that if the ECU needs renewing then it will set me back £700 plus labour to fit, ive already spent £250 with Honda when they tried to diagnose the fault.

Just wondering if anybody else has seen this issue.
any news ??
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Hi, sorry for not replying earlier, after a long discussion with Honda UK, they agreed to fund 50% of the ECU, and also local Honda Dealer discounted the labour costs. So all in all the job cost me £300, thats additional to the £220 that the Honda dealer had already charged me for diagnostics. So £520 cost to me in total, and its been running fine for a few weeks now.
 
1 - 10 of 10 Posts
Top