2006+ Honda Civic Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi

I've obtained a manual for my Civic but my own multi function display doesn't seem to work as per the manual:

According to the manual you press and hold 'i' and then repeatedly press 'i' to cycle through the various options, and select the one you want with 'sel/reset'.

However when I press and hold 'i' I seem to already be in the speed warning menu, and pressing 'i' only cycles through the available options for the speed warning. There is an 'exit' option, but this exits completely and not to a higher level menu.

I wanted to set the trip A auto reset when you fill with fuel option, but as above I don't seem to be able to get to that menu option.

Does anyone know what I'm talking about? :) or can anyone shed any light on how it is supposed to work, assuming my manual is incorrect? Or is my display faulty? :confused:

Thanks!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Thanks for the replies

I'm pretty sure the handbrake was on when I tried it, but I'll have another go in the morning at let you know.

Cheers!
 

·
Registered
Joined
·
353 Posts
The display on mine works as stated in the manual, but it is the 09 version. Is your manual the correct edition as you appear to be operating the system correctly.

Unless you are holding the 'I' to long your display may be faulty of the main menu corrupted.
 

·
Registered
Joined
·
353 Posts
Have you got the problem sorted yet? Checked my car last night with the hand brake off and got the same results as you.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7 (Edited)
Thanks for asking, but sadly I still can't figure it out...

I've definitely got the correct manual, but no matter what I try I can't get the display off of the speed warning.

If anyone has any other ideas they would gratefully be received! Otherwise I guess I'll have to get it looked at.

Cheers!
 

·
Registered
Joined
·
353 Posts
The only thing I can think of is that the trip computor isnt getting a handbrake on signal. is the handbrake symbol appearing on the dash panel?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
The only thing I can think of is that the trip computor isnt getting a handbrake on signal. is the handbrake symbol appearing on the dash panel?
I think you've nailed it - many thanks! The is no handbrake light when it is applied, so as you say the computer must think it is still off, and so will only display the speed warning.

A trip to the dealer beckons.....!

Thanks again!
 
1 - 9 of 9 Posts
Top