2006+ Honda Civic Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi,

This problem is beginning to irritate me. About 6 months ago, my brake pads were gone, so I had brand new discs and pads fitted all round. Went for some high quality pads n discs, and they have served me well. I barely done 4000 miles since I have fitted them and now there is a noise that has started to develop on the left front side of the vehicle everytime a brake under 20mph after a good 15 minute drive. I have my mechanic inspect the vehicle and it seems to be completely fine. I had my tyre changed as one of my tyres were warped, so had 4 brand new tyres fitted, but the same problem is still there.

It only ever happens on the left front side, and gets worse when more people are sitting in it.

Any suggestions.
 

·
Administrator
Joined
·
17,936 Posts
Check the caliper sliders are well lubed and moving freely?

Ensure the back of the pads and carrier guides are copper slipped?

Might it be the stone guard rubbing?

Wheel bearing maybe?

Did the garage check these or anything else?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Check the caliper sliders are well lubed and moving freely?

Ensure the back of the pads and carrier guides are copper slipped?

Might it be the stone guard rubbing?

Wheel bearing maybe?

Did the garage check these or anything else?
Thanks for this. I will return back to the garage and ask them to check. Is it possible for a brake pad to get knackered that quick too? Last thing I want is them changing my brake pads at an additional expense.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4 (Edited)
So I had it checked. The calipers were moving freely, copper grease was applied, he dismantled, cleaned and reapplied everything, but the noise is there. He resitted the brake pad and still same thing. Grrr!
 
1 - 4 of 4 Posts
Top