2006+ Honda Civic Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hello guys,

I have installed the FD2 oil pump in my FN2 along wiyth spoon Baffle sump, the problem si now in full acceleration the engine gas is cut-off, the check engine lights on the dashboard along with VSA, and it's cutting the fuel at 4k rpm.

The only error is this:
P2646 HONDA VTEC Oil Pressure Switch Circuit Low Voltage


And yes, the oil level is right.

Any idea what my cause this?

Thanks!
 

·
Premium Member
Joined
·
1,775 Posts
Was the sump in good condition? as it sounds like it's being starved of oil somehow....I've not fitted one yet but do you need to prime the pump with oil before instillation or anything as does seem very strange
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Was the sump in good condition? as it sounds like it's being starved of oil somehow....I've not fitted one yet but do you need to prime the pump with oil before instillation or anything as does seem very strange
The pump and sump are NEW!
 

·
Premium Member
Joined
·
1,775 Posts
Just digging and found this .....
Reset the ECM first. If the code comes back check for continuity in the oil pressure switch with the ignition off. No continuity= replace the oil pressure switch. Check for resistance between the VTEC solenoid and body ground. Resistance should be 14-30 Ohms. If it isn't replace the VTEC
Hope this helps a bit pal
 

·
Premium Member
Joined
·
1,775 Posts
Haven't fitted to mine yet pal
 

·
Registered
Joined
·
35 Posts
Discussion Starter #9
Found the problem, I did not knew about the oil jet plug (between the two vacant bolt holes) that needs to be removed. When installing a K20 oil pump it's important this is blocked off otherwise it can lead to a big drop in oil pressure.
 

·
Premium Member
Joined
·
2,241 Posts
Found the problem, I did not knew about the oil jet plug (between the two vacant bolt holes) that needs to be removed. When installing a K20 oil pump it's important this is blocked off otherwise it can lead to a big drop in oil pressure.
Thats the one.
 

·
Clutch pedal guru
Joined
·
5,127 Posts
Check the oil pressure. There's no way I'd be trying to 'VTEC' it after you've missed plugging an oil gallery. Has there been any engine damage due to the ommission of the plug?
 

·
Registered
Joined
·
23 Posts
Sorry, my bad. I have not had the pump replaced only the VTEC Oil Pressure Switch Circuit sensor changed, but that has not resolved the issue, I will continue in my original post rather than jump around. Had poor access to internet before, but now that I am back home will get this sorted easier.
 
1 - 18 of 18 Posts
Top