2006+ Honda Civic Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi i have a fn2 2007 i just got a new pcv valve has any one changed theirs if so did you change the hose as well?
Thanks


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
378 Posts
anyone used the American imported one.

More Information for BECK/ARNLEY 0450357

mines playing up as have done the little test. going to order this one or £30 from Tegiwa, unless of course there cheap enough from Honda.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Bought one from tegiwa for £30 its an oem honda part dunno how much you pay for from a honda dealership might be worth a call first bud


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I hear it sorts out oil consumption which mine does and reduces risk of oil leaks so worth the money imo


Sent from my iPhone using Tapatalk
 

·
Enjoying life
Joined
·
8,557 Posts
Cox do the complete kit, think I paid £38. Got it in about 1 day too.
 

·
Premium Member
Joined
·
378 Posts
I've ordered one for £12 delivered from USA. Even as a spare it's ideal

Will ring Honda today also
 

·
CTR
Joined
·
538 Posts
How can you tell if you need to replace it?
 

·
Enjoying life
Joined
·
8,557 Posts
How can you tell if you need to replace it?
If you raise the bonnet and can hear a scratchy sound (hard to describe), give the pipe on the intake mani a quick squeeze and if the sound stops then it's likely the pcv valve needs replacing. Quite a common thing.
 

·
CTR
Joined
·
538 Posts
Excellent thanks @flashy, will have a listen tonight.
 

·
CTR
Joined
·
538 Posts
Defo mines is knackered, when I pinched the hose noise went away.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
140 Posts
If you raise the bonnet and can hear a scratchy sound (hard to describe), give the pipe on the intake mani a quick squeeze and if the sound stops then it's likely the pcv valve needs replacing. Quite a common thing.
Thanks for this, was driving me crazy, thought it was the pulley or the VTEC solenoid valve, still cant seem to find a replacement for the 1.8, still never noticed a rough idle or excessive oil usage!

Sent from my SM-G920F using Tapatalk
 
1 - 20 of 43 Posts
Top