2006+ Honda Civic Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Yesterday i changed the fuel filter on my 2008 2.2 CTDI and have since had the error PGM-FI on the dash and the P1031 code on the OBD reader. Admittedly i did crank over the engine a few times (which is when it appeared) before discovering the manual fuel pump bong thing. Once i discovered it and pressed it several times it started fine. The error PGM-FI on the dash comes up within seconds of the ignition on. When i used the OBD the code P1031 comes up which im able to clear BUT as soon as i do it comes back again (Also the error PGM on dash). This isnt effecting my cars driving at all but its annoying.

Any ideas on how to reset or get rid of this code? I have already tried the on/off 3 times trick.

My next steps i think are to take car apart again and unclip the fuel sensors / water sensor / maf sensors that were taken off during the fuel filter change and leave for half hour and try again.

Any help appreciated! Billy.
 

·
Bye bye Honda...
Joined
·
5,865 Posts
It's a fuel heater circuit malfunction. I'm guessing you knocked the fuel heater connections loose when replacing the fuel filter?
 

·
Bye bye Honda...
Joined
·
5,865 Posts
Me neither, at least on the Civic. I had an Accord and the heater was adjacent to the filter.

Logically it should be somewhere you've been working though, or you wouldn't have disturbed it?

I've just looked in the official Honda workshop manual for your Civic and the fuel heater is located above/behind the filter in the schematic, as though you are standing in front of the car looking under the bonnet.

The manual also says there's a software fix for P1031 problems, but if was OK before you did the filter then I guess it probably isn't the software!
 

·
Registered
Joined
·
8 Posts
Hello,my civic 2.2d 2006 got this error code P1031 after a jolt on a small hole in the street.I removed the error with my obd2 reader but comes up again,flashing the engine light .I also removed all the cables go to the fuel filter and installed again with same error.Jon,you mentioned there is a software solution on this,could you please let me know more about it in order to fix this?
 

·
Clutch pedal guru
Joined
·
5,127 Posts
Check the wiring and heater for continuity.
 
  • Like
Reactions: Jon_G

·
Bye bye Honda...
Joined
·
5,865 Posts
Hello,my civic 2.2d 2006 got this error code P1031 after a jolt on a small hole in the street.I removed the error with my obd2 reader but comes up again,flashing the engine light .I also removed all the cables go to the fuel filter and installed again with same error.Jon,you mentioned there is a software solution on this,could you please let me know more about it in order to fix this?
Sorry, but the manual doesn't go into details. You'd need to discuss it at a dealers.

However I strongly doubt that this is a software fault, as it was previously ok prior to this incident. The jolt must have disturbed something somewhere, possibly even the heater element has been broken (like a lamp filament)?

As Hondacivicnut says, you need to users multimeter and check that the heater filament still has continuity. Then check the wiring as best you can... I'm guessing there's only power at the heater below a certain temperature, so you'd need to wait until it's really cold and then see if there's any voltage present, which isn't very convenient!

If it's not the heater that's failed then you may be best to see an autoelectrician, as the wiring will be hard to check without diagrams.
 

·
Registered
Joined
·
8 Posts
Thanks for your messages guys.To check voltage,im not sure because dont know the correct values that the fuel heater element or rest circuit has.I went to 2 auto electricians but couldnt locate where this error came from as all connections were tested ok.
Tomorrow i will go to a honda ecu tuning specialist to test and find where this error comes from,because ecu might need reprogramming after this strong jolt.
 

·
Bye bye Honda...
Joined
·
5,865 Posts
Was the actual heater tested to make sure it hadn't been broken? Or the relay?

A strong jolt could never affect the ECU programming!
 

·
Registered
Joined
·
8 Posts
Yes,ECU was checked and didnt have any problem.The fuel heater element that you said,its in the fuel filter housing p/n 16900-RSR-E01?Because im thinking to buy a used one and check if the error will disappear.
 

·
Registered
Joined
·
8 Posts
Hi Jon and sorry for my late replay as i didnt check this problem further until today which i got a used part (fuel filter housing p/n 16900-RSR-E01) with a brand new fuel filter,but same error code P1031 .Also i test both elements and have electrical continuity with ohmmeter.Im frustrated because even honda service here dont know about diesel cars and current problem from which part is. What other do or someone else believe is coming from?Maybe is there any second fuel heater somewhere else in the car except fuel filter housing?
 

·
Registered
Joined
·
81 Posts
Pretty basic, but did you check the fuel heater fuse? If it's not that... It's definitely some connection back there or it would've disappeared after you cleared it.
 

·
Registered
Joined
·
81 Posts
Yes, then you must have knocked a nearby cable for the fuel heater or didn't plug one of them back in properly... Or one of the connections you put back in was bad (corrosion? so a pin or two aren't properly connected?). I can't imagine any other reason.
 

·
Registered
Joined
·
8 Posts
Hi Sab,yes i test with my mechanic all these that you described and all seem well connected without corrosion or loose.3 days ago i got something new and maybe is related to this error.When i try to start the car,it doesnt start (like when you run out of fuel) and when i use the fuel line hand primer and then the car starts with the first ignition.Again when stop the engine and try after a few seconds to start the engine,it doesnt start.Maybe this problem is related to the previous i have.My mechanic said that probably (not sure 100%) is the fuel pressure valve part number 0928400576 that makes all this trouble.Is that possible even if i dont get any other error code?
 
1 - 17 of 17 Posts
Top