2006+ Honda Civic Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
183 Posts
Discussion Starter #1
Hi everyone

Quick question. I've recently upgraded to a double din. The Pioneer AVH-X3500DAB. I also purchased the Complete fitting kit from Hondabitz Civic Complete Fitting Kit RHD and the pioneer patch lead. Also the DAB antenna.

However the fitter who is installing this is saying that none of these leads are compatible with the FN2 for the controls to work on the steering wheel. Everything else is fine except that. Am i missing something here?
 

·
Premium Member
Joined
·
338 Posts
Why are they not compatible? Has he tried ?

I've not seen any other issues - I've got them and sterring wheel control works a treat
 

·
Premium Member
Joined
·
183 Posts
Discussion Starter #7
I didn't order the connect 2 lead. I got what was on my first post and the pioneer patch lead.

He said it wouldn't work and he even phoned around and they said it wasn't made for the FN2. Has he wired it up wrong somewhere? Everything else works except the volume on the steering wheel.
 

·
Premium Member
Joined
·
821 Posts
I didn't order the connect 2 lead. I got what was on my first post and the pioneer patch lead.

He said it wouldn't work and he even phoned around and they said it wasn't made for the FN2. Has he wired it up wrong somewhere? Everything else works except the volume on the steering wheel.
It is the correct kit for the FN2. In fact the instructions for it look very similar to the Connects2 kit as well.

Basically, he hasn't followed the instructions properly. It specifically says on step 4: "Connection from the interface to the car harness must be made last". I know from experience, my steering wheel controls didn't work when I first fitted my radio because I connected the car harness before connecting the patch lead.

You can try disconnecting the battery for 5 mins and see if that resets it and gets it working. Otherwise, he'll need to disconnect everything and follow the instructions.
 

·
Premium Member
Joined
·
183 Posts
Discussion Starter #9
It is the correct kit for the FN2. In fact the instructions for it look very similar to the Connects2 kit as well.

Basically, he hasn't followed the instructions properly. It specifically says on step 4: "Connection from the interface to the car harness must be made last". I know from experience, my steering wheel controls didn't work when I first fitted my radio because I connected the car harness before connecting the patch lead.

You can try disconnecting the battery for 5 mins and see if that resets it and gets it working. Otherwise, he'll need to disconnect everything and follow the instructions.
Cheers fella. I'll give him a ring tomorrow and see what he has to say
 

·
Dervinator
Joined
·
1,349 Posts
And iirc make sure the key is not in the ignition when connecting as well.

That sounds like someone who has done this "Eleventy Bazillion times" so hasn't bothered to read the destructions !!
 
1 - 10 of 10 Posts
Top