2006+ Honda Civic Forum banner

21 - 40 of 50 Posts

·
Registered
Joined
·
127 Posts
I did the missing characters fix today.

I found it difficult to remove the triangular plastic trim, and the speedo display. They required quite a bit of force, I thought I was going to break something! I used plastic pry tools to assist.

My soldering skills are crap, but it appears to have worked (time will tell how well). I did notice some black stuff in the solder when heating up the pads, which I think may be the protective lacquer coating burning off?

I didn't re-lacquer after, but hopefully should be ok :smile3:
 

·
Registered
Joined
·
1 Posts
I can confirm its working with satnav radio as well. Been having the display issue and poping sound that increase after i've install amp+sub and in hot weather could't listen music for more than 5 minutes. Followed the excellent instructions and now its all gone. Thanks dude for going to trouble to write this thread.
*could't attach picture in the post*
 

·
Registered
Joined
·
10 Posts
Somebody didn't have a spare part for the housing for the segment display? I just broke it. It is a left sided car.
Thank you
I can not insert any link, so i can send you pictures PM
 

·
Registered
Joined
·
1 Posts
Radio segments

I have an issue with my type r with all led segments lite up and audio poping noise at the same time the radio turns itself on and off.: crying::crying::crying:
Is this the same fix?
 

·
Registered
Joined
·
14 Posts
Have an issue with the screen but never any popping noise or radio turning off. Will have to take a look at the screen when i take the dash off this week.

Unfortunately i dont have a soldering iron, though i have access to a lazer welder at work, would be a bit worried about frying someting though!, and also how the car would be without the screen in, and whether the alarm would set ok?
 

·
Premium Member
Joined
·
885 Posts
The car without screen is fine and no issues with setting alarm. I had no screen for a week ** i finally got round to soldering pins.

Sent from my SM-N915G using Tapatalk
 

·
Registered
Joined
·
14 Posts
Tried to take the screen off tonight...... got everything else removed but the screen wouldnt release on the left hand side.

I pulled fairly hard, even rocking back and forward, worried about a broken screen!
 

·
Registered
Joined
·
9 Posts
Careful with polarities and temperature, I managed to break my head unit ceramic capacitors and circuit board, had to get a another one :/
 

·
Registered
Joined
·
4 Posts
Hi,

I have this problem and I'm completely new to soldering and the likes, anyway someone can link me to what I need to buy in order to get me started?

For the capacitor, I've been on cpc.farnell.com and it's the only site I can find anything close to what I may or may not need for this job.
I've found (potentially) three options on cpc.farnell

As for resistors I've been on mouser.co.uk and there's around 100 options.

Cannot post links (yet) as I am under the post count as to what I have found.

Any assistance with this is greatly appreciated.

I need and want to learn and there's no time like the present, I have my brother who has past experience with soldering but I'll need the parts first and I'll be giving it a go with his guidance I guess :D

So boring driving without the radio working all the time :(
 

·
Registered
Joined
·
82 Posts
Had the issue described in Problem 2 - characters randomly missing. A whack to the top of the display seemed to bring it back sometimes.

I have a friend with a fancy soldering iron with a small tip, the pins are very small and spaced very close together. Wouldn't attempt this with your common cheap soldering iron.

Been about a year now and the fix has worked.
 

·
Registered
Joined
·
45 Posts
Hi xfiniti64!

A year ago I resoldered display. I have civi Mk8 1.8 petrol yesterday I accedentally kicked on volume radio button / or AC button. After that accident the whole row with AC on the display dissapeared.
Does anybody know if that is faulty radio, faulty air condition controls or faulty display?

Sent from my Mi-4c using Tapatalk
 

·
Registered
Joined
·
45 Posts
I'm not so sure. There are two signals which go from climate control unit to radio unit. One is DISP CLK and AC SO. I do not know what they do...

E4*RED*Climate control unit (DISP CLK)*
E5*YEL*Climate control unit (AC SO)*

Sent from my Mi-4c using Tapatalk
 
21 - 40 of 50 Posts
Top