2006+ Honda Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Wonder if someone has this same issue, I've trawled through but nobody seems to have had same problem as me with my 2006 2.2 EX.

The radio keeps cutting out (with a loud bang / speaker pop) then coming back to life briefly before cutting out again ..... absolutely driving me nuts. I've tried just about every event I can to find a pattern to the problem and recreate the scenario without success. The only continous similarity is it only occurs after about 45 mins or so. Makes no difference if on Radio or CD.

Sounds either like a bad earth, exposed live or a knackered head unit. Once the unit has cooled down (over night etc), the 45 mins starts again.

PLEASE HELP!!!!!

Suggestions appreciated :D

Dont want to give up on the civic just yet (yes I would for such a small problem - Go back to my usual VAG car) if it is a known fix, as it's sooooo damn cheap & practical (pretty crap at everything else, nasty & noisy sums it up)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
It seems to be linked somehow to the clock displaying all characters, albeit slightly dimmer than the ones I'm interested in ..... :confused:
 

·
Premium Member
Joined
·
355 Posts
If it's temperature dependent, ie happens when hot/warmed up, it's either an I.C (chip), or a dry joint (bad soldering). Dry joints are easy to rectify with a soldering iron, faulty I.C's not so. Either way it's a headunit out job.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Thanks, looks like I'll have to pull it out and see if I can spot anything obvious. Smelt of burnt plastic a couple times today and getting worse.

You never know, could be a smouldering heap on the drive in the morning, which will save me a job!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Well, pulled everything out yesterday, took the head unit to pieces and nothing looks obviously wrong.

Give it all a good blow over and circuit tested the PCB ..... everything is fine.
Put it all back together, same cutting out after 45 mins or so along with the temp display / clock showing all characters.

Must be chip issue therefore now need a factory EX head unit. Better put a wanted ad in.
 
1 - 5 of 5 Posts
Top