2006+ Honda Civic Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi guys, just had a few hot days and went to use my aircon. What followed was a pretty pungent smell, I can't really describe what it was like but it was definitely unbearable.

From what I felt for the brief time it was on the output was pretty cold. Would this indicate that there's a leak in the system and not something a simple regas would cure?
 

·
Administrator
Joined
·
17,942 Posts
I doubt it, more likely a bacteria/nasty build up on the internal matrix.

When did you last change your pollen filter?

You can buy AC bombs that cleanse the internal vents/matrix/blower.

How often do you run with AC on?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
That's what I thought. I'm booking a service soon as I've only owned it a couple of months, I'll check the pollen filter as I believe it's a year since it's last service. Also going to look into A/C bombs too. Thanks for the quick reply and I'll share if I get it sorted!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Checked the pollen filter and it was filthy. New one on the way but I'm certain I'll need a bomb. Hopefully that does the trick!

Will the smell come back if the A/C isn't used regularly allowing moisture to build up?


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
17,942 Posts
Yeah, if you don't use your A/C regularly then it tends to honk.

You're advised to keep switching it on regularly to ensure the seals/etc stay lubed.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Makes sense! Hopefully a fresh pollen filter and a bomb will have it good as new.

Would you advise getting the system regassed as well so everything's fresh? I have no evidence of it ever being done
 

·
Administrator
Joined
·
17,942 Posts
Tough call.

Some will say, if it ain't broke then don't fix it.
I
But a regas from a competent AC specialist shouldn't be expensive and would give you piece of mind.

If it's still blowing cold, then it's working fine so I'd leave it be.
 
1 - 8 of 8 Posts
Top