2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Hi All.

Car in question: -

Civic 2.2 SE 2008 - 40k on the clocks.

Earlier, I was driving along with my lights on and my speedo display started flickering and then for a while actually stopped functioning. After I stopped and turned off the car, it was then working fine when I restarted.

Is the start of something terminal? I got AA Gold Warranty for 12 months from the independent dealer I bought the car from.

Cheers,

Jon.
 

·
Registered
Joined
·
42 Posts
What kind of flickering? Does the reading fluctuate to 0? or is the display completely off? Are there other dashboard lights coming up? When driving, does the reverse lock engage? (to prevent the clutch putting it in reverse)
 

·
Registered
Joined
·
273 Posts
Discussion Starter #5
Exactly as Grayfox just described. Just the speedo flickering on and off with 888 displayed.

Does the problem tend to get worse, or is it something that may never happen again?
 

·
Super Moderator
Joined
·
7,124 Posts
Don't know.

It happened to me after a 5 months of owning the car and it was intermittent.

I told them about it during my service they said they will have to book it in for diagnosis.
The next day it did it so i took a picture of it while driving at 50km/h.

Showed honda the next day, they said OK we will just order the part.

Took about 1.5 weeks for it to come, had to learn to judge speed by engine RPM and what gear i was in.

Was replaced and been fine since
 

·
Living the dream!
Joined
·
8,543 Posts
The display dims down or shows 888 as the speed or flickers on or off.

yes been here and done it and it is a rare but common fault if you know what I mean. Mine was repaired under warranty but if I had to pay for this I would have gone over the speedo soldering joints as I suspect a dry joint and ours only mainly did this when it was very hot
 
1 - 7 of 7 Posts
Top