2006+ Honda Civic Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Used the car this morning and all in order.
Went out again late morning and when I turned the key, the rev counter/fuel gauge and temp gauge remained in total darkness and all at zero.
All warning lights came on and stayed on.
Digital speedo was illuminated but showed zero and remained at zero when I drove.
Went directly to my local dealer (albeit not where I purchased the car) hoping it might be something simple such as fuses.
Dealer said if I could leave the car with them they'd check it that afternoon.
Within 3 hours called to say problem rectified for now but that they will order a new speedometer assembly and call me back in to fit same within the next week.
I have no idea what failed and why but will establish same when car goes in for replacement.
Full marks to ALM Honda in Macclesfield, Cheshire, for such fantastic service on this occasion.
Anyone else had a similar problem ?
 

·
Premium Member
Joined
·
833 Posts
Full marks to ALM Honda in Macclesfield, Cheshire, for such fantastic service on this occasion.
I took my car there for it's service, even though it's a good distance out of the way though, great service and friendly people! Want to know if they still have the full set of alloys for £300 though! Guessing not.
 

·
Premium Member
Joined
·
1,615 Posts
Which alloys for £300 ? dont cost much to ring then up find out, better than wasted trip.
 
1 - 6 of 6 Posts
Top