2006+ Honda Civic Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
As above has anyone resolved that problem? I have cleaned the egr a couple of thousand miles ago, it now has the brand new manifold fitted.

I checked the imrc valve today and can move the push rod easily, I have been reading about the frequency solenoid, have many people fixed the issue this way.

My honda happiness check has already thrown up two bump stops, arb links and corroded back brakes to sort as well as two tyres. Have been looking at some frequency solenoids on eBay, is there a way to identify if my car has the revision part fitted already fitted or if any of the salvaged parts are revised ones?

Thanks in advance
Tom
 

·
Premium Member
Joined
·
11 Posts
I had the same issue on my old Alfa 147, egr had been of a couple of times and it started to feel like it was missing at around 1500rpm. In the end all it was a leaking egr to manifold gasket, i had just refitted old gasket when i put it back together. New gasket fitted and back to super smooth.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Just To update this for anyone reading I have managed to sort this. I had a code for throttle position sensor coming on obd reader. I bought a throttle body of ebay with tips attached. When I removed my old on it was obvious that the flap on the tps was sticking when trying to close due to being coked up. The new one was clean so I fitted it and seems to work a treat.

Tom
 
1 - 3 of 3 Posts
Top