2006+ Honda Civic Forum banner
1 - 20 of 26 Posts

·
Premium Member
Joined
·
57 Posts
Discussion Starter · #1 ·
Hi,

All of a sudden my 2.2 CDTI Civic EX 06 Plate is flashing up with a VSA warning then a ABS warning both warnings happen at the same time and show up whenI break to a near enough stand still and don't go away until I turn off the engine and then back on the error is then clear until i pick up a bit of speed and break and then the error occurs again.

Anyone idea what this can be and cost to fix this also is it common? It just suddenly come on when I was driving my break fluid has been low but I topped it up before when these warnings appeared but this has not resolved the issue.

Thanks
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter · #3 ·
Thanks for the reply Pottsy Ive been and checked the fuses this morning and ABS and VSA motor one is ok, it seems to come on as soon as I brake heavily.

Ive not actually filled the brake fluid up it was the clutch fluid I didn't realise, so my plan today is to fill the brake fluid.

What is the worst case scenario the VSA motor? Also whats the best case scenario a wheel sensor? How much would I be looking at? I am going to get it booked into a dealer for the end of the month as go on holiday today.

AND ITS ACTUALLY ABS LIGHT FLASHING UP FOLLOWED IMMEDIATLEY BY A VSA LIGHT. Thanks
 

·
Cockup Specialist
Joined
·
12,885 Posts
You have a magnetic sensor behind the brake disk with a channeled metal cylinded as part of the hub that passes the sensor when the wheel is moving.
This gear and sensor gets aboslutely clogged with debris after a while.
If this is metallic brake dust....it will interfere.

If the wheel sensor bust...the ABS and VSA think that the wheel has locked.
Do you feel / hear a rumbling through the brake pedal when the ABS light is on ?
Is your brake fluid topped up ?
Are you leaking brake fluid from anywhere ?
Has yoru ABS wire detached from the back of the hub ?

Immaterial anyway....dealer job matey ;)
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter · #5 ·
Just a quick update after taking out the ABS fuse in the interior and putting it back in I have not had the error occur again, going to take it for anothr spin in a bit and see how I get on.

I rang the dealer earlier booked it in £65+vat for a code read, however I am going to cancel if the error has disappeared.
 

·
Premium Member
Joined
·
13,427 Posts

·
Registered
Joined
·
8 Posts
I know exactly what the problem is as my civic 1.8 suffered from it last year,
It's the brake pedal switch located on the brake pedal,it has two terminals,they burn out so sometimes when you brake it illuminates the vsa/abs light on the dash.
Bought a new one from eBay £30.00,fixed
Hope this helps folks.
 

·
Premium Member
Joined
·
18,080 Posts
Interesting, if the brake pedal switch is broken then if you unplug it will the error stay away?

If this switch is busted then do the brake lights still work? They won't if you unplug the brake pedal switch...

Darn electric's...
 

·
Registered
Joined
·
1 Posts
abs vsa trouble

hi just recently driving along, the abs vsa warning light came on the dash, which comes and goes and is intermittent.

then just the other day it came on and now wont go out. have checked all the abs sensors/ sensor plugs and abs sensor rings are all clean etc.

I have also tried to reset the fault using foil causing a short connection,

the only fault code that came up was

PA 10 DTC B1008

I have tried to re-set the fault by holing the reset/select button for 10 second, the dash then shows me the following flashing

DTC NO ?

Also when I brake hard just to check my brakes are working, there is a quite high pitch beep coming from in the car (from behind dash)

please can anyone help and point me in the correct direction to solve this issue.
 

·
Registered
Joined
·
287 Posts
Had the same issue recently, initially intermittent then on permanently took it to Honda and the code was 12 which is front offside abs sensor it was replaced and is ok now. I strongly suspect you have a faulty sensor your 10 code might indicate a rear wheel sensor, cleaning it won't solve it.
 

·
Registered
Joined
·
2 Posts
This happened to me only a few weeks ago, intermittent flashing between the VSA and ABS logo on the main part of the dash, I looked at the posts regarding the brake pedals but it wasn't them, it ended up being an ABS sensor on the wheel and cost £160 to fix (I was relieved to say the least)
 

·
Registered
Joined
·
49 Posts
Same issue here, except it goes away for a while and when the error isnt there, during braking I can hear the abs kicking in at times until the warning comes back and then theres nothing else from the abs
 

·
Registered
Joined
·
5 Posts
I have a similar issue: ABS/VSA comes on after driving for ~10 minutes. If i stop for ~30-60 minutes it goes away for the next 10 minutes driving.....

I read the DTC codes on the dash using the method mentioned above, but i only had PA51 codes (airconn), which indeed had some problems with the relays. I can't see any errors with PA10 mentioned above. How can i find out what triggers the ABS/VSA warning without error code :-/
 

·
Premium Member
Joined
·
14 Posts
I had similar intermittent ABS/VSA codes. With a suspect battery swapped out (I had other reasons for thinking a battery fault - like it not holding a charge about 12V for more than a few seconds after power off) it sorted them for 2 weeks but last week them came back and after a slow speed ABS activation for no reason (I had virtually stopped at the time) the lights came on full time.
Since my car had a warranty on it I let a garage sort it but beforehand I did try a Bosch diagnostics unit which failed to even see the ABS ECU to read the fault. Luckily the garage did manage it and swapped out the failed sensor for me earlier this week (note to self - ask them which sensor it was).
 

·
Registered
Joined
·
91 Posts
I'm having same issue, comes and goes. Nothing major to worry about I guess..

Sent from Tapatalk
 

·
Registered
Joined
·
91 Posts
if its starting to come and go you have a fault developing or the sensor or ring on hub/drive shaft is dirty
get a fault code read donr so you can sort it before it fails full time
I'll take a read next time, thanks a lot! ??

Sent from Tapatalk
 

·
Super Moderator
Joined
·
2,982 Posts
I'll take a read next time, thanks a lot! ??

Sent from Tapatalk
mine started by only poping up after about 9 miles if i left car about half hour or more light went out it was like this for a week or more
then it started to come on sometimes as soon as i got in car in morning then fully on all the time
 
1 - 20 of 26 Posts
Top