2006+ Honda Civic Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello all, I am the second our 2006 1.8 Civic iShift and Honda UK was the first company owner. Since we had the car at 2 years old the battery has gone flat quite regularly. The car has been jump started on many occasions.

For about 8 months the car has a VSA warning light on. The car has been to two Honda main dealers who diagnosed a couple of engine codes (Intake Air Temp, Mass Airflow sensors) and I think no communications with the VSA unit.

Both dealers said it was a wiring fault and spent time diagnosing it. I have spent about £500 so far and the fault just comes back after a couple of days. It does not seem to be a wiring fault to me - for example when I ask if the wiring was cut etc I don't get a clear answer. Last time they said the codes would not clear so they reprogrammed the ECU. They also fitted a new battery - this is the 4th battery on a 2006 car.

I think the ECU could be faulty/damaged and somehow loses or corrupts some of the programming.

I have been quoted £1200 to replace the ECU with a new unit. To fix the MICU fusebox issue will be another £500. I have that there is recall for a MICU fault in the fuse box, bot I checked with Honda who said it does not apply to my car.

Does anyone know if I could use a second hand ECU ? I believe it would need to be re-programmed to the car (immobiliser etc?) assuming Honda would want to do this?

Is there any independent specialist that could help in the London/SouthEast area?

Thanks in advance for any advice.
 

·
Super Moderator
Joined
·
7,124 Posts
If you car has HFT disconnect it.
It has a known issue for a parasitic draw which will drain the battery.

As for the VSA fault, that could be due to a bad wheel speed sensor.
 
1 - 2 of 2 Posts
Top