2006+ Honda Civic Forum banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
38 Posts
Discussion Starter #1
Hi all,

Whilst driving last night my dash display started to look like this, with every function lit up...



Shortly after, the radio cut out. It then switched back on around 20 seconds later, then cut out again. This cycle repeated a few times until the radio finally stayed on for the rest of the journey.

Any ideas what the problem is?
 

·
Premium Member
Joined
·
136 Posts
hi there sounds like it could be a voltage problem in the electrical system
check the alternator output is within limits between 13to 14 volts at battery with engine running
it might be worth disconnecting the battery for 10 mins and see if it resets itself
 

·
Registered
Joined
·
5 Posts
You could try the display test technique? car off, switch to 1st stage ignition, press and hold down number 1 & 6 in the cd player buttons, then press the power on/off button at then let go of all three at the same time. / To turn off display check simply push the off button. Sometimes holding 1 & 6 then tapping the on/off button twice also works. Give it a go. It might trip it back to normal again. If I'm right 1&3 is for speaker check diagnostics but 1&6 is fro the full display check. If that doesn't work then disconnect the neg battery for 10 mins then reconnect. Clock and dash brightness will reset. Hope the 1&6& on/off button technique works for you.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter #5
Thanks for that link Farqui. Sounds exactly like the issue, but the repair seems a little beyond my electrical skill!

Problem is intermittent, screen was fine again today with a black background - I'll give the resetting procedure a go!
 

·
Premium Member
Joined
·
1,467 Posts
Thanks for that link Farqui. Sounds exactly like the issue, but the repair seems a little beyond my electrical skill!

Problem is intermittent, screen was fine again today with a black background - I'll give the resetting procedure a go!
I might help with repair mate if your interested. I have one refurbished unit.

Sent from my GT-I9300 using Tapatalk
 

·
Registered
Joined
·
18 Posts
Hi all,

Whilst driving last night my dash display started to look like this, with every function lit up...



Shortly after, the radio cut out. It then switched back on around 20 seconds later, then cut out again. This cycle repeated a few times until the radio finally stayed on for the rest of the journey.

Any ideas what the problem is?
Mine does this all the time. I have an EX so I have the sat nav and what not. Only really seems to "pop" I call it when I am doing journeys for longer than an hour and a half, so It's not really a massive deal until I'm on the motorway blasting my tunes and suddenly all I can hear is my own God awful singing ? been meaning to get it fixed but worried it will be a pain to fix (and I'm tight!)

Sent from my SM-A310F using Tapatalk
 

·
Registered
Joined
·
358 Posts
this was my excuse for finally upgrading to a double din unit. the original head unit is overheating and messes up the signal to the display. my oem radio was going on and off at its own will before I took the plunge and ripped it out! :)

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
31 Posts
this was my excuse for finally upgrading to a double din unit. the original head unit is overheating and messes up the signal to the display. my oem radio was going on and off at its own will before I took the plunge and ripped it out! :)

Sent from my SM-G935F using Tapatalk
What double din unit did you install?
 

·
Registered
Joined
·
31 Posts
AVH-X3800DAB | Pioneer

I got this. happy with it, but I wish it was a bit "snappier" going through the menu's. the audio quality is good though, and a massive improvement over the oem radio :)

Sent from my SM-G935F using Tapatalk
Was it an easy install and does it look ok? I'm gonna be looking at a double din shortly but unsure which to go for ?
 

·
Registered
Joined
·
358 Posts
Was it an easy install and does it look ok? I'm gonna be looking at a double din shortly but unsure which to go for ?
if you do a bit of read up before you start, it's an easy enough job. couple of hours of work I recon. you'll find some good how to guides if you search :) It looks really good :) you'll see pictures in the how to's mate!

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
103 Posts
I've had the same problem recently but the sound has been fine. I have the Sat nav version which I take it will cost more to replace because of the nav screen. I don't want to change the head unit to an aftermarket one as I like it all as it is.

Sent from my HTC One_** using Tapatalk
 
1 - 14 of 14 Posts
Top