2006+ Honda Civic Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
749 Posts
Discussion Starter #1
The sound seems to be coming from the right wiper blade right at the base in side of the dash somewhere. Its fine when the wiper is going up but when it comes back down to a stop in its default position you can here a slight click noise it almost sounds electrical. Anyone know what this problem is due to?

Thanks
 

·
Premium Member
Joined
·
749 Posts
Discussion Starter #2
Also, Ive noticed that my right hand side door handle has a keyhole. Is there meant to be a cover for this?
 

·
Registered
Joined
·
144 Posts
The sound seems to be coming from the right wiper blade right at the base in side of the dash somewhere. Its fine when the wiper is going up but when it comes back down to a stop in its default position you can here a slight click noise it almost sounds electrical. Anyone know what this problem is due to?

Thanks
Maybe the relay?? :popcorn2:
 

·
Premium Member
Joined
·
2,202 Posts
Do you have auto wipers? If so it is probably the relay and is normal. Try running the wipers in non auto mode to see if the sound remains.

Sent from my GT-I9300 using Tapatalk
 

·
A/C fixer-upper'er
Joined
·
856 Posts
That click certainly is the relay, on mine you could hear it at the start and finish of every wipe motion when in auto, nothing to worry about.

And the keyhole is meant to be uncovered, I've certainly not seen an example of a cover for the keyhole on any civic ever. Some foreign users of this site have complained that the lock is on the wrong side, so if central locking fails you have to climb over to the left hand side seat (drivers in left hand drive vehicles), but that's because this is primarily a British market car with the lock on the correct side of the car for the RIGHT side drivers seat!
 

·
Premium Member
Joined
·
749 Posts
Discussion Starter #6
It probably is the relay. Also when using the hi or low setting on the wipers, does turning the speed dial do nothing?
 

·
A/C fixer-upper'er
Joined
·
856 Posts
Are you referring to the rain intensity ring on the wiper stalk, or moving the stalk up from auto to low to high positions?

The ring sets how much rain falls on your screen before the sensor activates a wipe, try to set it slow enough in very light rain so that the wipers aren't rubbing dry across the screen. The high / low manual settings on the stalk just wipe at set durations and can't be adjusted.
 
1 - 7 of 7 Posts
Top