2006+ Honda Civic Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
138 Posts
Discussion Starter #1
I fitted new Honda wipers and after a short while got the smudge line from the passenger wiper blade, could even see it on the screen in the morning after rain, I tried all sorts to get rid of it with no luck. Until that is I spoke to a mobile valet chap and also looked on the Rainex web site.
The valeter asked what I had tried, answers washing up liquid, glass cleaner, water spot remover, meths, was getting close to 0000 wire wool at this point, he said "that your car" went over to it and cleaned the screen with dilute Autosmart APC a couple of times, no more smudge, had loads or wiper use over the last few days, still clear, the screen is amazingly clear... incredible so I will be getting some.
The other thing I noticed is that Rainex suggest cleaning new wiper blades before fitting, this made me think that there may be some silicone or dressing or something either left from the manufacturing process, or to protect the blades in storage on them that deposits itself on the screen.
Hope this helps someone
 

·
Premium Member
Joined
·
272 Posts
I fitted new Honda wipers and after a short while got the smudge line from the passenger wiper blade, could even see it on the screen in the morning after rain, I tried all sorts to get rid of it with no luck. Until that is I spoke to a mobile valet chap and also looked on the Rainex web site.
The valeter asked what I had tried, answers washing up liquid, glass cleaner, water spot remover, meths, was getting close to 0000 wire wool at this point, he said "that your car" went over to it and cleaned the screen with dilute Autosmart APC a couple of times, no more smudge, had loads or wiper use over the last few days, still clear, the screen is amazingly clear... incredible so I will be getting some.
The other thing I noticed is that Rainex suggest cleaning new wiper blades before fitting, this made me think that there may be some silicone or dressing or something either left from the manufacturing process, or to protect the blades in storage on them that deposits itself on the screen.
Hope this helps someone
I have this too tried all sorts clay bar,APC,glass cleaner took blades off cleaned them loads of times and reapplied rain repent to no avail!!!
Ill try this too thanks.
Where's best to buy as i don't want a 5L tub?

Sent from my SM-G975F using Tapatalk
 

·
Premium Member
Joined
·
138 Posts
Discussion Starter #3
I also tried clay and wheel cleaner with no better result, all he said was Autosmart APC he sprayed it on and went over the screen with a microfibre cloth twice quite quickly - job done.
He said if it worked to let him know and I could buy a small amount from him next time he ordered, next time I see him most likely in a week or so I will ask if it is the G101 and how much he dilutes it by and let you know.
 

·
Premium Member
Joined
·
272 Posts
I also tried clay and wheel cleaner with no better result, all he said was Autosmart APC he sprayed it on and went over the screen with a microfibre cloth twice quite quickly - job done.
He said if it worked to let him know and I could buy a small amount from him next time he ordered, next time I see him most likely in a week or so I will ask if it is the G101 and how much he dilutes it by and let you know.
Many thanks

Sent from my SM-G975F using Tapatalk
 

·
Premium Member
Joined
·
138 Posts
Discussion Starter #6
Could be Das, when the car was serviced after it was cleaned the paint had that smeared look about it perhaps whatever does that was on the screen. I clean the car with a wax shampoo then go over the glass with cleaner so maybe it's something I'm doing, could be a combination of allsorts of yuk, seems odd though that you can't nuke the stuff off.
 

·
Registered
Joined
·
19 Posts
Looks like you will be joining the wiper smearing club. I have exactly the same problem tried everything to get rid and my smear is on the drivers side right in my eye line but it's something I have to live with it seems

Sent from my CLT-L09 using Tapatalk
 

·
Premium Member
Joined
·
313 Posts
I have same problem even with brand new bosch aerotwin, 2 inch smear right in centre of wiper and eyeline.

Sent from my ONEPLUS A3003 using Tapatalk
 

·
Registered
Joined
·
19 Posts
I have same problem even with brand new bosch aerotwin, 2 inch smear right in centre of wiper and eyeline.

Sent from my ONEPLUS A3003 using Tapatalk
Exactly the same what a weird and annoying problem


Sent from my CLT-L09 using Tapatalk
 

·
Premium Member
Joined
·
313 Posts
I wonder if the wiper has very finely worn a groove in the screen making it slightly lower, then the blade misses this point.

Sent from my ONEPLUS A3003 using Tapatalk
 

·
Premium Member
Joined
·
138 Posts
Discussion Starter #11
Saw the detailer chap today, he used Autoglym, (not Auto Smart as I originally posted), APC or G101 diluted with water to 10:1 he gave me some so I am out of the wiper smudge club, the screen is still fine.
Anyone needing a good valet in the Redhill Surrey area give him a go https://www.barrysvalet.co.uk
 

·
Premium Member
Joined
·
138 Posts
Discussion Starter #12
Sorry folks old age creeping on, it was right first time AutoSmart not Autoglym, in the blue 5L container... NURSE...
 
1 - 12 of 12 Posts
Top