2006+ Honda Civic Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
Hi I'm new on here Help!!

My missus came to pick me up from work in my 58 type s gt and whilst in the car park for 5 MINS she left the lights on. When i moved her to the passenger seat ;) to drive us home i turned the key and the airbag symbol started flashing then when i pressed the start button everything went out and NOTHING:facepalm:

Any ideas on what it may be PLEASE anyone?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Yes it seems that everything works until i press the start button...
then everything goes dark and nothing..
 

·
Premium Member
Joined
·
1,274 Posts
Batteries dead. Try jump
Starting with a another battery from somewhere.
 

·
Muscles From Brussels
Joined
·
4,073 Posts
never leave electrical things on without engine on! I went and sat up listening to music with a girl on a first date car wouldnt start miles away from anyone had to make her get out and push the car!!!! I have NEVER done it again!
 

·
Premium Member
Joined
·
645 Posts
never leave electrical things on without engine on! I went and sat up listening to music with a girl on a first date car wouldnt start miles away from anyone had to make her get out and push the car!!!! I have NEVER done it again!

Ahh but did it get you a 2nd date ;)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
Just got a mate to jump start it and it is now fine thanks for advice and putting my mind at rest.

Thanks a lot... Happy now:)
 
1 - 14 of 14 Posts
Top